$re = '/^(?:(\d+)(\d{2})|(\d{1,2}))$/m';
$str = '1
12
123
12345678';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);