$re = '/(?=.*\d.*\d)(?=.*[A-Z].*[A-Z]).{8,}/m';
$str = 'foo1Bar2Qux
foo
bar
123
QX12
1fooBAR2';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);