# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^[a-zA-Z\d]+(?=([-_])?)(?:\1[a-zA-Z\d]+)*$"
test_str = ("-test\n"
" : false \n"
"test-\n"
" : false\n"
"te--st\n"
" : false\n"
"test\n"
" : true\n"
"test-test\n"
" : true \n"
"te-st-t\n"
" : true \n"
"te-st_test\n"
" : false\n"
"te_st_test\n"
" : true")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.