$re = '/^\#(
[0-9a-fA-F]{6}|
[0-9a-fA-F]{3}
)$/mx';
$str = '#000
#123
#90a
#abc
#def
#fff
#000000
#890ABC
#ABCDEF
#ffffff
#1
#12
#1234
#12345
#1234567
#ggg
#XYZ
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);