import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(<ComponentSearchFormField(?:[^<]*?))(\\s+)type=\"inputSearch\"((?:[^>]*?)\\/>)";
final String string = "\n"
+ " <div className=\"ui celled grid\">\n"
+ " <div className=\"row\">\n"
+ " <ComponentSearchFormField\n"
+ " columnWidth=\"8\"\n"
+ " type=\"inputSearch\"\n"
+ " model={depositPrototype}\n"
+ " field=\"company\"\n"
+ " sourceCollection={Companies}\n"
+ " baseCriteria={{isActive: true}}\n"
+ " />\n"
+ " <ComponentSearchFormField\n"
+ " disableValidation\n"
+ " type=\"inputSearch\"\n"
+ " model={depositPrototype}\n"
+ " disableValidation\n"
+ " title=\"Currency Code\"\n"
+ " sourceCollection={CurrencyCodes}\n"
+ " baseCriteria={{isActive: true}}\n"
+ " />";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}