#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?muix)(\w+(-\w+)+)"
Local $sString = "fhkjhjfsa fjasio-fakjfas-fjsahjfkas fajskl-fas fhsajhfkjsa " & @CRLF & _
"" & @CRLF & _
"fasjlk-fas-jfksaljfklas fasfjsak jkfs kflaj s"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")