import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:(?:fix|feat|docs|doc|breaking|revert|chore|perf|test|style|refactor)(?:\\([\\w\\s]+\\))?:).*(?:(?:OS[:\\-\\s]\\s*([0-9]+))|((?:ska|SKA)-(?:[0-9]+))).*";
final String string = "chore: Mudanças de configuração ou de ska-7777 código que não entra em produção;\n"
+ "docs(sdsdsds): Mudanças na documentação ska-7777;\n"
+ "style: Alteração apenas no estilo do código, ska-7777 sem mudança de algoritmo;\n"
+ "refactor: Refatoração de determinado ska-7777 bloco de código;\n"
+ "perf: Alterações que impactam o desempenho da aplicação OS 99999;\n"
+ "test: Mudanças na OS:99999 estrutura ou na forma de testar o projeto.\n"
+ "feat: dksdOS: 99999jskdjksdksdskdjkjk\n"
+ "fix: dsdsdsdsd OS: 99999";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}