use strict;
my $str = 'chore: Mudanças de configuração ou de ska-7777 código que não entra em produção;
docs(sdsdsds): Mudanças na documentação ska-7777;
style: Alteração apenas no estilo do código, ska-7777 sem mudança de algoritmo;
refactor: Refatoração de determinado ska-7777 bloco de código;
perf: Alterações que impactam o desempenho da aplicação OS 99999;
test: Mudanças na OS:99999 estrutura ou na forma de testar o projeto.
feat: dksdOS: 99999jskdjksdksdskdjkjk
fix: dsdsdsdsd OS: 99999';
my $regex = qr/^(?:(?:fix|feat|docs|doc|breaking|revert|chore|perf|test|style|refactor)(?:\([\w\s]+\))?:).*(?:(?:OS[:\-\s]\s*([0-9]+))|((?:ska|SKA)-(?:[0-9]+))).*/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}