re = /^(?:(?:fix|feat|docs|doc|breaking|revert|chore|perf|test|style|refactor)(?:\([\w\s]+\))?:).*(?:(?:OS[:\-\s]\s*([0-9]+))|((?:ska|SKA)-(?:[0-9]+))).*/m
str = 'chore: Mudanças de configuração ou de ska-7777 código que não entra em produção;
docs(sdsdsds): Mudanças na documentação ska-7777;
style: Alteração apenas no estilo do código, ska-7777 sem mudança de algoritmo;
refactor: Refatoração de determinado ska-7777 bloco de código;
perf: Alterações que impactam o desempenho da aplicação OS 99999;
test: Mudanças na OS:99999 estrutura ou na forma de testar o projeto.
feat: dksdOS: 99999jskdjksdksdskdjkjk
fix: dsdsdsdsd OS: 99999'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end