$re = '/(^([\w\.\-]+)@([\w\-])+((\.(?!EMAIL)(?!email)(?!com\.com)([a-zA-z]){2,9}){1,6})$)|(^$)/m';
$str = '
renanpcosta@gmai.com
renanpcosta@hotmail.com.br
lucas@smf.curitiba.pr.gov.br
lucas@sga.pucminas.br
lucas@ga.unicamp.br
lucas@smf.curitiba.pr.gov.br
lucas@.com.com.com
lucas@com.com.com.com.com.com
lucas@com.com.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);