// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?<match>(?'nine'9|0|18|27|36|45|54|63|72|81))").unwrap();
let string = "0
9
18
27
36
45
54
63
72
81";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}