import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<b>(.*)<\\/b>";
final String string = "somestring<b>Test:<br>\n"
+ "EUR/USD - "Expect for <i>PRICE BREAKOUT</i>"<br>\n"
+ "Sell : 1.06809<br>\n"
+ "Target : 1.06309<br>\n"
+ "Stop Loss : 1.07309</b><br>rest of html";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}