re = /<b>(.*)<\/b>/
str = 'somestring<b>Test:<br>
EUR/USD - "Expect for <i>PRICE BREAKOUT</i>"<br>
Sell : 1.06809<br>
Target : 1.06309<br>
Stop Loss : 1.07309</b><br>rest of html'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end