#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^https?:\/\/[^\/]+\/?(\?.*)?$"
Local $sString = "http://example.com" & @CRLF & _
"https://example1.com" & @CRLF & _
"https://example2.com/" & @CRLF & _
"http://anything.com/?test=12" & @CRLF & _
"http://anything.com?test=12" & @CRLF & _
"" & @CRLF & _
"http://example.com/path" & @CRLF & _
"https://example.com/path1/path2" & @CRLF & _
"https://example.com/path1?test=123"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")