use strict;
my $str = 'This is a test of my regular expression.
Well.
123 Main Street.
150 Stupid fart.
Saucy Noob.
123 fuk
123 Fruity Licker
Lol.';
my $regex = qr/[\d]+[\s][\w]+[\s^][\w]+\.?/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}