// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"[\d]+[\s][\w]+[\s^][\w]+\.?").unwrap();
let string = "This is a test of my regular expression.
Well.
123 Main Street.
150 Stupid fart.
Saucy Noob.
123 fuk
123 Fruity Licker
Lol.";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}