package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\s+(\D)`)
var str = ` JLABCD-1 836397-BTD56517`
var substitution = "$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}