re = /^(?P<category>\D+)\s+(?P<value>[\d.]+)\s+(?P<unit>.+)/m
str = 'Weight 229.6104534866 g
Energy 374.79170898476 kcal
Total lipid (fat) 22.163422468932 g
Carbohydrate, by difference 13.641848209743 g
Sugars, total 4.3691034101428 g
Protein 29.256342349938 g
Sodium, Na 468.99386390008 mg '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end