import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "Pattern\\[\\d+\\]:\\s*Key[^\\n]*\\s*Value[^\\n]*";
final String string = "Pattern[1]: \n"
+ "Key : \"key1\" \n"
+ "Value : 100\n"
+ "Pattern[2]: \n"
+ "Key : \"key2\" \n"
+ "Value : 20\n"
+ "Pattern[3]: \n"
+ "Key : \"key3\" \n"
+ "Value : 30\n"
+ "Pattern[4]: \n"
+ "Key : \"key4\" \n"
+ "Value : 220";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}