re = /Pattern\[\d+\]:\s*Key[^\n]*\s*Value[^\n]*/
str = 'Pattern[1]:
Key : "key1"
Value : 100
Pattern[2]:
Key : "key2"
Value : 20
Pattern[3]:
Key : "key3"
Value : 30
Pattern[4]:
Key : "key4"
Value : 220'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end