re = /(?P<year>\d+)-(?P<month>\d+)-(?P<day>\d+) (?P<hour>\d+):(?P<minute>\d+):(?P<second>\d+)/
str = '2018-04-18 02:55:37'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end