#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\{(?:(?:A=1()|B=2()|C=3())(?>,|\}$)){3}\1\2\3$"
Local $sString = "{A=1,B=2,C=3}" & @CRLF & _
"{B=2,A=1,C=3}" & @CRLF & _
"{C=3,B=2,A=1}" & @CRLF & _
"{A=1,B=2,A=1}" & @CRLF & _
"{B=2,B=2,C=3}" & @CRLF & _
"{A=1B=2C=3}" & @CRLF & _
"{A=1}B=2}C=3}" & @CRLF & _
"{C=3,B=2,A=1,}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")