use strict;
my $str = '{A=1,B=2,C=3}
{B=2,A=1,C=3}
{C=3,B=2,A=1}
{A=1,B=2,A=1}
{B=2,B=2,C=3}
{A=1B=2C=3}
{A=1}B=2}C=3}
{C=3,B=2,A=1,}';
my $regex = qr/^\{(?:(?:A=1()|B=2()|C=3())(?>,|\}$)){3}\1\2\3$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}