Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Reg
ular
Ex
pressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
(?:^(?:(\d+)')?(?:[-| ]*)(?:(\d*(?: ?\d+\/\d+)?|(?:\d*\.\d+)?)?")?$)
/
gmi
Input 1
1
New
5'-2 1/2" 5' -2 1/2" 5' 4 2/3" 5'-4" 5'3 1/4" 4" 1/8" 5'-3.25" 5' 3.25" 5'3.25" 3.25" .25" 345'-12.318"