// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\s*\?\s*(.*?)\s+\d+(?:\.\d+)?[kM]?").unwrap();
let string = " ? 5girls 57k
? acoustic guitar 1.4k
? bass guitar 4.2k
? black choker 144k
? black dress 227k
? black footwear 275k
? black pants 133k
? black ribbon 128k
? black shirt 201k
? black shorts 117k
? blue eyes 1.7M ";
let substitution = "$1,";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}