import Foundation
let pattern = #"^\s*\?\s*(.*?)\s+\d+(?:\.\d+)?[kM]?"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
? 5girls 57k
? acoustic guitar 1.4k
? bass guitar 4.2k
? black choker 144k
? black dress 227k
? black footwear 275k
? black pants 133k
? black ribbon 128k
? black shirt 201k
? black shorts 117k
? blue eyes 1.7M
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1,"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)