# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"-(?=-)|(?<=\d)-(?=\d+(-\d+)?$)"
test_str = ("--1234\n"
"-123-123-1234\n"
"-123-123\n"
"12.123.3\n"
"---123.13.123")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.