import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
    public static void main(String[] args) {
        final String regex = "^(_{2}\\([\\'\\\"]{1})([a-zA-Z1-9\\s%\\_\\'\\.\\,(\\\"\\))*\\(\\=\\>\\$\\-\\!]*[(\\){1,3})*(\\'\\)*)(\\){1,3})*(\\\"\\))*]+)";
        final String string = "__('Register and apply for %job_title%', array('%job_title%' => $job->getTitle()));\n"
	 + "__(\"Invalid File\".$something.\" Extension\");\n"
	 + "__(\"Employers9\");\n"
	 + "_sometime\n\n"
	 + "__('Please read the Privacy Policy and tick $the %ceva%box to say you have done so.!')\n\n\n\n\n"
	 + "__('Register and apply for %job_title%', array('%job_title%' => $job->getTitle())) \n"
	 + " \n\n";
        
        final Pattern pattern = Pattern.compile(regex);
        final Matcher matcher = pattern.matcher(string);
        
        if (matcher.find()) {
            System.out.println("Full match: " + matcher.group(0));
            
            for (int i = 1; i <= matcher.groupCount(); i++) {
                System.out.println("Group " + i + ": " + matcher.group(i));
            }
        }
    }
}