import Foundation
let pattern = #"some text(?:(?!some text|two).)*two"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"some text blah blah one some text blah blah two."#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)