using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(IMG_.+\s*.*\..+.*\s*)(IMG_.+\s*.*\..+.*)";
string substitution = @"*from*\n$1$2\n\n*to*\n$2";
string input = @"IMG_7892.jpg | 3
Bilqis.JPG | 7
IMG_7892.jpg | 1
Bilqis.JPG | 8";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}