const regex = /(IMG_.+\s*.*\..+.*\s*)(IMG_.+\s*.*\..+.*)/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(IMG_.+\\s*.*\\..+.*\\s*)(IMG_.+\\s*.*\\..+.*)', 'gmi')
const str = `IMG_7892.jpg | 3
Bilqis.JPG | 7
IMG_7892.jpg | 1
Bilqis.JPG | 8`;
const subst = `*from*\n$1$2\n\n*to*\n$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);