// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)(IMG_.+\s*.*\..+.*\s*)(IMG_.+\s*.*\..+.*)").unwrap();
let string = "IMG_7892.jpg | 3
Bilqis.JPG | 7
IMG_7892.jpg | 1
Bilqis.JPG | 8";
let substitution = "*from*\\n$1$2\\n\\n*to*\\n$2";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}