package main
import (
    "regexp"
    "fmt"
)
func main() {
    var re = regexp.MustCompile(`(?i)(select top [0-9]+ percent|select top [0-9]+|select )`)
    var str = `seLect top 21 campo, campo from tabela select top 100 percent teste 2 top `
    
    for i, match := range re.FindAllString(str, -1) {
        fmt.Println(match, "found at index", i)
    }
}