import re
regex = re.compile(r"(select top [0-9]+ percent|select top [0-9]+|select )", flags=re.IGNORECASE)
test_str = "seLect top 21 campo, campo from tabela select top 100 percent teste 2 top "
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")