package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)(CHE-\d{3}\.\d{3}\.\d{3}\ +(IVA|TVA|MWST))`)
var str = `CHE-123.456.789 MWST
CHE-123.456.789 TVA
CHE-123.456.789 IVA
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}