// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)(CHE-\d{3}\.\d{3}\.\d{3}\ +(IVA|TVA|MWST))").unwrap();
let string = "CHE-123.456.789 MWST
CHE-123.456.789 TVA
CHE-123.456.789 IVA
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}