import Foundation
let pattern = #"(?i)(CHE-\d{3}\.\d{3}\.\d{3}\ +(IVA|TVA|MWST))"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
CHE-123.456.789 MWST
CHE-123.456.789 TVA
CHE-123.456.789 IVA
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)