package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<script.*?"(http.*?)"`)
var str = `<script type="text/javascript" src="http://chrismills.la/test.js"></script>`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}