$re = '/^(?!baz).*\.exe$/m';
$str = 'foo.exe
foo.dmg
baz.exe
this-is-another-file-name.exe';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);