#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?xm)(?(DEFINE)" & @CRLF & _
" (?<exprs> (?&expr)(\s+(?&bool)\s+((?&expr)|\(\s*(?&exprs)\s*\)))* )" & @CRLF & _
" (?<expr> (?&valleft)\s?(?&comp)\s?(?&valright) )" & @CRLF & _
" (?<comp> ((!=)|(==)|(<=)|(>=)|(<)|(>)){1} )" & @CRLF & _
" (?<valleft> (?¬)[\w\.]+ )" & @CRLF & _
" (?<valright> [\w\.]+ )" & @CRLF & _
" (?<bool> (and|or) )" & @CRLF & _
" (?<not> (not\s+)?)" & @CRLF & _
")" & @CRLF & _
"(?&exprs)"
Local $sString = "common.test == 1 or ts==12 and (nlabla<=10 or er==22 or blabl==11 and ere==2 and (bbbb==21 and gg==12) and test==13)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")