import Foundation
let pattern = #"""
(?(DEFINE)
(?<exprs> (?&expr)(\s+(?&bool)\s+((?&expr)|\(\s*(?&exprs)\s*\)))* )
(?<expr> (?&valleft)\s?(?&comp)\s?(?&valright) )
(?<comp> ((!=)|(==)|(<=)|(>=)|(<)|(>)){1} )
(?<valleft> (?¬)[\w\.]+ )
(?<valright> [\w\.]+ )
(?<bool> (and|or) )
(?<not> (not\s+)?)
)
(?&exprs)
"""#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .allowCommentsAndWhitespace])
let testString = #"common.test == 1 or ts==12 and (nlabla<=10 or er==22 or blabl==11 and ere==2 and (bbbb==21 and gg==12) and test==13)"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)