re = /cn=[\w- ]+,ou=(?<ldap_myvalue>\w+).+,ou=people,dc=mysite,dc=com/
str = 'cn=test-1 test,ou=outest,ou=people,dc=mysite,dc=com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end