#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?ism)<a (.*?)href="(.+?)"(.*?)>(.*?)<\/a>"
Local $sString = "<a href="http://www.google.be">Google</a>" & @CRLF & _
"<a href="bestand.flv" test="blablabla">bestand</a>" & @CRLF & _
"<a target="_blank" href="Titels_opdrachten.pdf"><strong>titels van opdrachten in OLAT</strong></a>" & @CRLF & _
"" & @CRLF & _
"<a id="5quot;>test</a>" & @CRLF & _
"<a href="hallo.png">hallo</a>"
Local $sSubst = "<a href="$2">$4</a>"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)