# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<a (.*?)href="(.+?)"(.*?)>(.*?)<\/a>"
test_str = ("<a href="http://www.google.be">Google</a>\n"
"<a href="bestand.flv" test=\"blablabla\">bestand</a>\n"
"<a target="_blank" href="Titels_opdrachten.pdf"><strong>titels van opdrachten in OLAT</strong></a>\n\n"
"<a id="5quot;>test</a>\n"
"<a href="hallo.png">hallo</a>")
subst = "<a href="$2">$4</a>"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.IGNORECASE | re.DOTALL | re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.