use strict;
my $str = '-L/usr/local/lib -lmylib -lz';
my $regex = qr/^-L(.+)\s+\K-l(.+)(?=\s+.+)/p;
my $subst = '$1/$2.a';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";