#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mx)^(?!.*THIRD.*(?:SECOND|FIRST)) # SECOND or FIRST cannot appear after THIRD" & @CRLF & _
"(?!.*SECOND.*FIRST) # SECOND cannot appear before FIRST" & @CRLF & _
"(?!.*THIRD.*THIRD) " & @CRLF & _
"(?!.*SECOND.*SECOND)" & @CRLF & _
"(?!.*FIRST.*FIRST)" & @CRLF & _
"(?=.*FIRST).*"
Local $sString = "FIRST" & @CRLF & _
"FIRST SECOND" & @CRLF & _
"FIRST SECOND THIRD" & @CRLF & _
"SECOND THIRD FIRST" & @CRLF & _
"SECOND FIRST THIRD" & @CRLF & _
"THIRD SECOND FIRST" & @CRLF & _
"FIRST FIRST" & @CRLF & _
" SECOND FIRST THIRD" & @CRLF & _
"FIRST SECOND SECOND" & @CRLF & _
"The word FIRST is mandatory ; it can appear only once" & @CRLF & _
"The word SECOND can appear zero or one time" & @CRLF & _
"The word THIRD can appear zero or one time" & @CRLF & _
"Order: FIRST, then SECOND then THIRD"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")