use strict;
my $str = 'FIRST
FIRST SECOND
FIRST SECOND THIRD
SECOND THIRD FIRST
SECOND FIRST THIRD
THIRD SECOND FIRST
FIRST FIRST
SECOND FIRST THIRD
FIRST SECOND SECOND
The word FIRST is mandatory ; it can appear only once
The word SECOND can appear zero or one time
The word THIRD can appear zero or one time
Order: FIRST, then SECOND then THIRD';
my $regex = qr/^(?!.*THIRD.*(?:SECOND|FIRST)) # SECOND or FIRST cannot appear after THIRD
(?!.*SECOND.*FIRST) # SECOND cannot appear before FIRST
(?!.*THIRD.*THIRD)
(?!.*SECOND.*SECOND)
(?!.*FIRST.*FIRST)
(?=.*FIRST).*/mxp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}