$re = '/^[_a-z0-9-\+.-]+(\.[_a-z0-9-]+)*@?([a-z0-9+\-]+\.)*[a-z0-9+\-]*$/im';
$str = 'u
us
user@
user@@
user@dom
user@example.com
user@example..com
user@@www.example.com
u@w.e..com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);