use strict;
my $str = 'https://bosym.de/index.php?s#instagram
https://www.google.de/?gws_rd=ssl
https://soundcloud.com/mcmainiac
www.wetter.info
http://www.web.ninja/';
my $regex = qr/(?<Address>(?<Protocol>https?:\/\/)?(?<Subdomain>\w*\.)?(?<Domain>(?:[a-z0-9\-]{2,})\.(?:[^\s\/\.]{2,}))(?<Path>\/[^\s\?]*)?(?<Params>(?:\?|\#)[^\s\/\?\:]*)?)/ip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}