#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)<p>@@@LINK=(.+?)</p>"
Local $sString = "<p>@@@LINK=ten pence</p>" & @CRLF & _
"<p>@@@LINK=twenty-twenty vision</p>" & @CRLF & _
"<p>@@@LINK=fifty pence</p>" & @CRLF & _
"<p>@@@LINK=abate</p>"
Local $sSubst = "<a href="x-dictionary:d:\g<1>:dict_bundle_id">\g<1></a>"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)